Search Results
Post Author Forum Replies Views Posted [asc]
    Thread: Using Distant Horizons
Post: Using Distant Horizons

Hello. I've decided to make Distant Horizons mod compatible with 1.20.4, altought the official latest release is only compatible with 1.20.1 Posting one picture right now, more coming later on :)
buvarbela Vanilla High Showcase 0 321 05-22-2024, 01:48 PM
Powered by MyBB, © 2002-2024 MyBB Group - Theme designed by Rōshi © 2015-2024.
This site is not affiliated by Mojang AB, makers of Minecraft. Brands, trademarks and copyrights belong to their respective holders.